Image

Currently, I have Google Chrome 33.0.1750 installed on Ubuntu 13.10. I noticed, recently, that when I open a new tab the applications view was replaced by a google search widget and recent tabs listing. I didn’t launch apps frequently, so it was no big deal for me until I tried to open a tab that I had opened previously on my android phone. The button tabs from other devices was also removed (well just moved).

To acces tabs from other devices you have two options: launch it from menu->recent tabs (which didn’t work for me, it appeared blank) or press CTRL+H to show history and you’ll see at the top, the list of your devices and open tabs.

Image

It seems a lot of people doesn’t like this change, me either.

Cairo-Dock es un gran lanzador de aplicaciones para Linux, muy parecido al dock de Mac OS X. Recientemente cuando abría Google Chrome, creaba otro ícono en vez de sólo colocar un indicador debajo del lanzador. Al parecer el problema se debe a las web apps. Para evitar que duplique el ícono, sólo tienes que ir a las preferencias de Google Chrome y desactivar la opción “continue running background apps when Google Chrome is closed”.

Tambien te puede interesar https://cirovladimir.wordpress.com/2013/06/19/ubuntu-13-04-lanzadores-de-aplicaciones-java/

Fuentes:
https://bugs.launchpad.net/cairo-dock-core/+bug/1254771

En un proyecto estoy tratando de utilizar un control Calendar para agendar eventos. SmartGwt define propiedades básicas para los eventos: name, startDate, endDate y description -todos ellos se pueden mapear a otras propiedades con métodos como setStartDateField-

Si nuestro evento tiene otras propiedades, además de estas, podemos agregar los campos en los editores mediante los métodos setEventDialogFields y setEventEditorFields.

Al agregar un SelectItem al editor de diálogo, me aparecía el siguiente mensaje de error

[ERROR] [Desktop] – 08:37:54.799:MUP0:WARN:DynamicForm:isc_DynamicForm_2:[Class SelectItem] form item defined with no ‘name’ property – Value will not be saved. To explicitly exclude a form item from the set of values to be saved, set ‘shouldSaveValue’ to false for this item.

Supuestamente este error fue arreglado en las ultimas versiones (04/05/2012) pero en la versión 3.0 me seguía apareciendo.

Después de mucho batallar encontré que el problema sólo se me presentaba cuando hacía la depuración (debug) en Google Chrome. Utilicé Mozilla Firefox y ya no tuve problemas.

De ahora en adelante intentaré depurar mi código en Firefox.

Fuentes:
http://forums.smartclient.com/showthread.php?t=4934
http://www.smartclient.com/smartgwt/javadoc/com/smartgwt/client/widgets/calendar/Calendar.html#setEventDialogFields(com.smartgwt.client.widgets.form.fields.FormItem…)
https://code.google.com/p/smartgwt/source/search?q=%22form+item+defined+with+no%22&origq=%22form+item+defined+with+no%22&btnG=Search+Trunk 
http://www.smartclient.com/smartgwt/javadoc/com/smartgwt/client/widgets/form/fields/FormItem.html 

Para desarrollar aplicaciones GWT utilizo Eclipse y el plugin de Google. Mi navegador por default es Google Chrome así que lo más natural para mí fue utilizarlo para depurar el código. Pues realmente Chrome es una mala elección para esto, me di cuenta cuando un SelecItem no me mostraba las opciones y la aplicación en general era demasiado lenta. Así que si padeces alguno de estos síntomas, mejor prueba con otro navegador –Firefox 😉 –

Fuentes:
http://forums.smartclient.com/showthread.php?t=8159#aChrome
https://groups.google.com/forum/?fromgroups#!topic/google-web-toolkit/qfVFxoieOXg 

Recientemente he estado trabajando en un proyecto donde es necesario insertar vídeo en un a página web. Para realizar esta tarea podemos utilizar la etiqueta de HTML5 ‘<video>‘. Bueno, pues para que nuestro vídeo se pueda ver en los navegadores principales -firefox, chrome, ie, opera, safari- es necesario tener al menos 3 fuentes (source) de vídeo en los formatos mp4 (h264), webm (vp8) y ogg (theora).

En Linux podemos utilizar el comando avconv -antes ffmpeg- de la siguiente manera:

avconv -i original.mov nuevo.mp4 nuevo.webm nuevo.ogv

tal vez sea necesario que instales el paquete libavcodec-extra. Con esto, al final tendremos 3 archivos nuevos con los formatos requeridos, ya sólo habría que agregar las fuentes a la etiqueta ‘<video>’

<video style="width: 640px; height: 360px;">
 <source src="videos/nuevo.mp4" type="video/mp4"></source>
 <source src="videos/nuevo.webm" type="video/webm"></source>
 <source src="videos/nuevo.ogv" type="video/ogg"></source>
 <!-- Opcionalmente insertar vídeo en flash para soportar navegadores antiguos -->
 Lo sentimos, tu navegador no soporta la etiqueta de video.
 </video>

Fuentes:
https://developer.mozilla.org/En/Media_formats_supported_by_the_audio_and_video_elements
http://paulrouget.com/e/converttohtml5video/

Recientemente he tratado de utilizar Google Chrome como navegador predeterminado (debido a la rápidez que ofrece) a pesar de que no tiene funciones que a mi me son de mucha utilidad -p. ej. CTRL+TAB para intercambiar pestañas de forma MRU, no puedes poner etiquetas a tus favoritos, etc.- Además de estos problemas, al utilizar scribefire y querer agregar mi blog de worpdress jamás logra completar el proceso de autorización (esto puede ser por un error en scribefire pero en firefox no sucede así).

Entonces para agregar un blog de wordpress a scribefire en Google Crhome necesitas hacerlo manualmente, es decir, llenar todos los campos a la hora de agregar el blog de la siguiente manera

Asegurate que el campo API URL quede http://tublog.wordpress.com/xmlrpc.php

Listo! Con eso ya podrías agregar tu blog de wordpress a scribefire 😀

 

Hoy en la oficina me comentaron que salió la versión 10 de Google Chrome, así que de inmediato me dieron ganas de actualizar. Buscando en el menú e incluso en internet no encontré la forma de actualizarlo. Al final resulto ser muy fácil, sólo hay que abrir el Update Manager y te aparecerá la actualización.

A un compañero no le aparecía porque tenía actualizaciones pendientes, una vez que las realizó le apareció de inmediato. Si aún así no te aparece, asegurate de tener activado el repositorio de Google. Ve a Synaptic Package Manager y luego a Settings->Repositories->Other Software, busca la entrada “http://dl.google.com/linux/chrome/deb/&#8221;