jhipster – The engine “node” is incompatible with this module

jhipster_logo

En un proyecto generado con jhipster@4.5.6 me estaba marcando el error ‘The engine “node” is incompatible with this module’ al ejecutar el comando yarn install

El problema es que en esta versión el archivo packages.json tenía una línea que decía

“engines”: {
“node”: “^4.3”
}

mi versión de node es

node -v
v7.1.0

y de acuerdo a semver la especificación “node”: “^4.3” me permitiría solamente utilizar node 4.x
Puedes forzar la ejecución de yarn install de la siguiente manera

yarn install –ignore-engines

Esto fue corregido en versiones posteriores de jhipster, por ejemplo en la versión 4.10.2 el archivo packages.json especifica

“engines”: {
“node”: “>=6.9.0”
}

lo que permite utilizar versiones más recientes de node, v7.1.0 por ejemplo.

para actualizar tu proyecto de jhipster (primero actualiza jhipster con yarn global upgrade generator-jhipster) intenté utilizar el comando jhipster upgrade pero no pudo actualizar debido a que marcaba el mismo error. Para actualizar lo que hice fue simplemente volver a ejecutar el comando jhipster (equivalente a jhipster app)

fuentes:
https://github.com/gilbarbara/react-joyride/issues/131
https://docs.npmjs.com/misc/semver
https://yarnpkg.com/
https://nodejs.org/

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

w

Conectando a %s