ant4eclipse – Linked Resource does not exist!

mayo 11, 2011

I had to change from Ubuntu to openSUSE, at first everything seems to work smooth until I found this little glitches. I’ve tried just to copy my Eclipse installation from the backup to my brand new OS but it didn’t work so I had to install it again (uncompress it).
One of my worst headaches is solving project dependency but fortunately I found a way to ease this process.
With the migration I moved my files from /home/vladimir to /home/cirovladimir,  my eclipse workspace included. This led me to an error when I was trying to run the ant file I use to solve dependencies. The error description wasn’t very helpful, it just said “Linked Resource does not exist!”. I found this post which proposed to use the development version of ant4eclipse instead of the stable release, so I did it. I tried again and this time the error was more clear “The linked resource ‘/home/vladimir/Projects/Eclipse/tsj.estadisticas.model/src/tsj’ in project ‘tsj.estadisticas.web’ does not exist.”. This allowed me to spot the problem and change the path in the hidden file “.project” -which contained the references- accordingly.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: