Configurar JBoss 5.0.1.GA en Eclipse 3.4.1

marzo 24, 2009

Con la finalidad de hacer un “deploy” de una aplicación que estoy desarrollando instale el servidor de aplicaciones jboss. Para instalarlo basta con descomprimirlo en la carpeta de tu elección.
Una vez instalado hay que configurarlo en eclipse, esto lo haces mediante la ventana de servidores dando clic derecho para crear una nueva conexión al servidor.

Te mostrara el asistente para agregar el servidor

y al dar clic en siguiente es cuando empezaron los problemas

La solución a este error la encontré aquí. Resumiendo, hay que editar el archivo “CARPETA_ECLIPSE\plugins\org.eclipse.jst.server.generic.jboss_1.5….\servers\jboss5.serverdef” cambiando

<exclude name=”server/default/lib/mail.jar”>

por

<exclude name=”common/lib/mail.jar”>

y

<archive path=”${serverRootDirectory}/server/default/lib/mail.jar”>

por

<archive path=”${serverRootDirectory}/common/lib/mail.jar”>

Con ello ya podemos crear la conexion e iniciar o detener el servidor.

Una respuesta to “Configurar JBoss 5.0.1.GA en Eclipse 3.4.1”


  1. […] Configurar JBoss 5.0.1.GA en Eclipse 3.4.1 marzo, 2009 4 […]


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: